《网络工程师》备考指南


章节分值重要考点列举
计算机硬件基础3~4数据的表示、指令系统、流水线、CPU、Cache、 RAID、内存编址、可靠性
操作系统基础1~2进程管理、存储管理、文件管理、设备管理
系统开发与项目管理基础3~4软件生命周期、软件开发模型、开发概念、进度管理
知识产权和标准化1著作权、保护期限、产权人确立、侵权判断、商标权
网络体系结构2网络协议、OSI参考模型、TCP/IP体系结构
数据通信基础4~6信道传输速率、调制与编码、常见复用技术和相关标准、差错控制
广域网与接入网技术2~3HDLC、PPP、SONET/SDH、xDSL HFC、数据交换类型 IEEE
局域网技术6~10802标准、以太网技术、网桥、交换机、无线局域网、VLAN、TRUNK、GVRP、 STP、 综合布线系统、传输介质
网络互联与因特网技术20~25IP地址、子网划分、CIDR、 IP数据报、ARP、 ICMP、IPv6协议、TCP、UDP、QOS、路由基础概念、路由器基本配置、RIP、OSPF、BGP、ACL、NAT、Web、DNS、DHCP、FTP、Telnet、 电子邮件
系统与网络安全基础5~8计算机病毒、网络攻击、加密算法、密钥管理、数字签名、报文摘要、数字证书、入侵检测技术、安全协议、VPN、 防火墙
网络管理技术5~6Windows/Linux网管命令、Linux系统命 令、Linux 目录结构、Linux系统文件、SNMP协议、网络管理概念、网络存储、网络故障排除
网络规划和设计3需求分析、通信规范分析、逻辑网络设计、物理网络设计
计算机专业英语5 

一、存储技术

(1)DAS,NAS,SAN三种存储技术比较

NAS和SAN本质上的不同点在于NAS有自己的文件系统,而SAN的文件系统在应用程序服务器上而非存储服务器上。这样的不同点导致NAS是文件级别的数据传输,而SAN是基于块级别的传输。

存储基础知识

(2)RAID存储技术

左图为raid10、右图为raid5

图解RAID0,RAID1,RAID5,RAID10

二、无线网络技术

(1)无线局域网

无线局域网是通过无线信道来实现网络设备之间的通信,并实现通信的移动化、个性化和宽带化。通俗地讲,无线局域网是在不采用网线的情况下,提供以太网互联功能。

协议标准WIFI版本工作频段理想速率信道带宽
802.11bWiFi12.4GHz11Mbps20MHz
802.11aWiFi25GHz54Mbps20MHz
802.11gWiFi32.4GHz54Mbps20MHz
802.11nWiFi42.4/5GHz72Mbps(1×1, 20MHz) 150Mbps(1×1, 40MHz) 288Mbps(4×4,20MHz) 600Mbps(4×4, 40MHz)20MHz/40MHz(信道绑定)
802.11acWiFi55GHz433Mbps(1×1, 80MHz)867Mbps(1×1,160MHz) 6.77Gbps(8×8,160MHz)40MHz/80MHz/160MHz
802.11axWiFi62.4/5GHz 160MHz

(2)数据通信技术

1)电信号在电缆上的传输速度大约是200 000km/s,调制延迟626ms

2)卫星传输延迟大约270ms

(3)无线加密技术

最常用的加密方式有:WEP(共享秘钥)、WPA/WPA2、WPA-PSK/WPA2-PSK,最安全的是后者,使用了TKIP、AES算法

(3)计算机网络

OSI七层模型

OSI中的层功能TCP/IP协议族
应用层文件传输,电子邮件,文件服务,虚拟终端TFTP,HTTP,SNMP,FTP,SMTP,DNS,Telnet
表示层数据格式化,代码转换,数据加密没有协议
会话层解除或建立与别的接点的联系没有协议
传输层提供端对端的接口TCP,UDP
网络层为数据包选择路由IP,ICMP,RIP,OSPF,BGP,IGMP
数据链路层传输有地址的帧以及错误检测功能SLIP,CSLIP,PPP,ARP,RARP,MTU
物理层以二进制数据形式在物理媒体上传输数据ISO2110,IEEE802,IEEE802.2

局域网

以太网预备知识

TCP/IP协议族

UDP:无连接的,不可靠的

UDP 是一种轻量级的运输协议,它仅提供最小服务。UDP是无连接的,不可靠的。

UDP头部占8字节,源端口、目的端口、长度、校验和。

TCP

面向连接的、可靠的、流投递服务。

ICMP

ICMP是IP协议的附属协议,属于网络层协议

ARP

地址解析协议,通过目标IP,查询目标主机的MAC,实现IP与MAC的映射。

IP说

IPv4地址分类:

网络类型最大网络数IP 地址范围最大主机数私有 IP 地址范围
A126(2^7-2)1.0.0.0--126.255.255.2552^24-210.0.0.0--10.255.255.255
B16384(2^14)128.0.0.0--191.255.255.2552^16-2172.16.0.0--172.31.255.255
C2097152(2^21)192.0.0.0--223.255.255.2552^8-2192.168.0.0--192.168.255.255

IPv4专用地址注册表

D类地址:

D类地址控制块

IPv6详见:【IPv6笔记】

DHCP分配IP过程

服务器使用UDP67端口,客户端使用UDP68端口。

(1)DHCPdiscover

客户机向网络中广播DHCPdiscover数据包;原地址0.0.0.0,目的地址255.255.255.255

(2)DHCP服务器收到DHCPdiscover数据包,通过广播DHCPoffer数据包做出响应,包含IP、MAC、租约期。

(3)客户机收到第一个包做出响应,发送DHCPrequest数据包,告诉DHCP服务器需要使用哪个IP,并发送ARP

(4)DHCPack

租约期过一半时,通过发送request包续租原来的IP。租约期过87.5时,重新发送dhcpdiscover广播包重新获取新的IP。租约期默认为8天。

DNS域名系统

SOA:DNS数据库的来源

PTR查询:

dig -x 203.119.25.1 @114.114.114.114 得到 1.25.119.203.in-addr.arpa. 37 IN PTR a.dns.cn.

C:\Users\user>nslookup
默认服务器:  UnKnown
Address:  fe80::1

> set type=ptr
> 203.119.25.1
服务器:  UnKnown
Address:  fe80::1

非权威应答:
1.25.119.203.in-addr.arpa       name = a.dns.cn

解析顺序:本地DNS缓存、Hosts表、本地DNS服务器、根域名、顶级域名、权威服务器

根域名数据库

根服务器数据库

DNS记录类型

HTTP

FTP

SMTP

常用端口

应用层协议传输层协议端口号协议描述
FTPTCP20、21文件传输协议
SSHTCP22安全shell协议
TelnetTCP23远程登录协议,传输非加密,能不用则不用
DNSTCP/UDP53域名系统,解析使用UDP、复制使用TCP
HTTPTCP80超文本传输协议
SMTPTCP25简单邮件传输协议
POP3TCP110邮局协议3代
DHCPUDP67/68IP动态分配,客户端使用68,服务端使用67
TFTPUDP69简单文件传输协议
HTTPSTCP443安全http
BGP4TCP179边界网关协议的应用
SNMPUDP161/162简单网络管理协议
WinTCP3389Windows远程桌面
ProxyTCP8080代理端口

更多端口资料请访问 常用端口对照表

协议头部整理 点我下载

(4)网络安全

(5)路由协议

自治系统AS

内部网关协议

RIP 路由信息协议

OSPF 开放最短路径优先

外部网关协议EGP

边界网关协议BGP

路由器技术

NAT 网络地址转换
CIDR 无分类域间路由

网关协议原文链接:https://blog.csdn.net/u010603798/article/details/86689291

(6)系统及服务器

Windows系统

Linux系统

Windows系统和Linux系统的命令差异

简述WindowsLinux说明
文件列表dirls 
复制文件cpcp 
移动文件movemv 
获取文件typecat 
路由跟踪tracerttraceroute 
查看IP配置ipconfigifconfig 
pingpingping 
nslookupnslookupnslookup 
digdigdig 

(7)华为交换机/路由器命令

DHCP服务器配置

2019年5月:配置路由器Router1,网关为192.168.100.1

[Huawei] dhcp enable (启用dhcp服务器)
[Huawei] interface vlanif 123 (配置vlan123)
[Huawei-Vlanif123] dhcp select global (全局)
[Huawei-Vlanif123] quit
[Huawei] ip pool lan
[Huawei-ip-pool-lan] gateway-list 192.168.100.1 (配置网关)
[Huawei-ip-pool-lan] network 192.168.100.0 mask 24 (配置局域网IP)
[Huawei-ip-pool-lan] quit
[Huawei]

交换机配置

2019年下半年真题:

某企业的网络结构如图4-1所示。完成交换机的基本配置,请根据描述,将以下配置代码补充完整。

<Huawei> _system-view_
[Huawei] _sysname_ Switch
[Switch] _interface_ GigabitEthernet0/0/1
[Switch-GigabitEthernet0/0/1] port link-type _(5:trunk)_
[Switch-GigabitEthernet0/0/1] port trunk allow-pass vlan_(6:10)_
[Switch-GigabitEthernet0/0/1] quit
[Huawei] interface vlanif 10
[Switch-Vlanif10] ip address 10.10.1.1 255.255.255.0
[Switch-Vlanif10] quit

按照公司规定,禁止市场部和研发部工作日每天8:00~18:00访问公司视频服务器,其他部门和用户不受此限制。请根据描述,将以下配置代码补充完整。

[Switch] _(7:time-range)_ satimc 8:00 to 18:00 working-day
[Switch] acl 3002
[Switch-acl-adv-3002] rule deny ip source 10.10.2.0.0.0.0.255 destination 10.10.20.1 0.0.0.0 timc-range satime
[Switch] acl 3003
[Switch-acl-adv-3003] rule deny ip source 10.10.3.0.0.0.0.255 destination 10.10.20.1 0.0.0.0 timc-range satime
[Switch] quit

[Switch] traffic classifier c_market //_(8:创建一个c_market的流分类)_
[Switch-classifier-c_market] _(9:if-match)_ acl 3002 //将ACL与流分类关联
[Switch-classifier-c_market] quit

[Switch] traffic classifier c_rd
[Switch-classifier-c_rd] if-match acl 3003 //将ACL与流分类关联
[Switch-classifier-c_rd] quit

[Switch] _(10:traffic behavior)_b market //创建流行为
[Switch-behavior-b market] _(11:deny)_ //配置流行为动作为拒绝报文通过
[Switch-behavior-b market] quit

[Switch] traffic behavior b_rd
[Switch-behavior-b_rd] deny
[Switch-behavior-b_rd] quit

[Switch] _(12)_p_market //创建流策略
[Switch-trafficpolicy-p_market] classifier c_market behavior b_market
[Switch-trafficpolicy-p_market] quit

[Switch] traffic policy p_rd //创建流策略
[Switch-trafficpolicy-p_rd] classifier c_rd behavior b_rd
[Switch-trafficpolicy-p_rd] quit

[Switch] interface _(13)_
[Switch-GigabitEthernet0/0/2] traffic-policy p_market _(13)_
[Switch-GigabitEthernet0/0/2] quit

[Switch] interface GigabitEthernet 0/0/3
[Switch-GigabitEthernet0/0/3] traffic-policy _(14)_ inbound
[Switch-GigabitEthernet0/0/3] quit

交换机:2018-11

<HUAWEI> system-view
[HUAWEI] sysname Switch3 //交换机名称命令为Switch3
[Switch3] vlan batch 10 20 // 批量创建vlan
[Switch3] interface GigabitEthernet 0/0/3
[Switch3-GigabitEthernet0/0/3] port link-type trunk //连接核心交换机的是trunk,连接PC端的是access
[Switch3-GigabitEthernet0/0/3] port trunk allow-pass vlan 10 20 //允许vlan10 20通过
[Switch3-GigabitEthernet0/0/3] quit
[Switch3] interface GigabitEthernet 0/0/1
[Switch3-GigabiEthernet0/0/1] port link-type access // 连接PC端的是access模式
[Switch3-GigabitEthernet0/0/1] port default vlan 10 // 下连:默认允许vlan10通过
[Switch3-GigabitEthernet/0/1] quit


<HUAWEI> system-view
[HUAWEI] sysname Switch1
[Switchl] vlan batch (5)
[Switch1] interface GigabitEthernet/0/1
[Switchl-GigabitEthernetO/0/1] port link-type trunk
[Switchl-GigabitEthernet0/0/1] port trunk allow-pass (6)
[Switch1 -GigabitEthernetO/0/1] quit
[Switch1] interface vlanif 10
[Switch1-Vlanif10] ip address 192.168.10.1 24
[Switch1-Vlanif10] quit
[Switch1] interface vlanif 20
[Switch1 -Vlanif20] ip address 192.168.20.1 24
[Switch1 -Vlanif20] quit

静态路由实现网络互通配置,Switch1和Router1

[Switchl] ip route-static (9) //默认优先级
[Switchl] ip route-static 0.0.0.0 0.0.0.0 172.16.30.2(默认下一跳地址) preference 70
[Router] ip route-static (10:202.1.111.1) //默认优先级
[Router] ip route-static 192.168.10.0 255.255.255.0 172.16.10.1
[Router] ip route-static 192.168. 10.0 255.255.255.0 172.16.20.1 preference 7O
[Router] ip route-static 192.168.20.0 255.255.255.0 172.16.10.1
[Router] ip route-static 192.168.20.0 255.255.255.0 172.16.20.1 preference 70

配置NAT

[Huawei] acl number 3002
[Huawei-acl-adv-3002] rule 5 permit ip source 192.168.100.0 0.0.0.255 (允许源IP访问)
[Huawei-acl-adv-3002] quit
[Huawei] interface virtual-template 10 (创建虚拟接口模板10)
[Huawei-virtual-template 10] ip address ppp-negotiate
[Huawei-virtual-template 10] nat outbound 3002 (NAT出口流量匹配3002ACL)
[Huawei-virtual-template 10] quit
[Huawei]
路由交换配置总结

(1)port link-type 后面的可以为trunk、hybrid、access。


其他笔记

DMZ区域:两个防火墙之间的区域,又称隔离区,主要存放着一些公共服务器(DNS服务器、Web服务器)

IPS入侵防御系统:IPS技术可以深度感知并检测流经的数据流量,对恶意报文进行丢弃以阻断攻击,对滥用报文进行限流以保护网络带宽资源。

学习文档

为什么MTU值普遍都是1500

计算机网络基础知识总结

网络基础:https://learnku.com/articles/22104

华为路由器命令大全:https://blog.51cto.com/9821049/2136711

浅入理解 10BASE-T、100BASE-T4、100BASE-TX、100BASE-FX

IP基础知识全家桶